imitone community

Building a universal, human-friendly music interface. ...But first we have to fix the bugs!

You are not logged in.

Announcement

Having trouble with imitone? Hit send on any Error Reports it creates, or use the in-app "send feedback" button.

#1 Re: Feedback and Suggestions » 'Equalize' standalone and VST(3) versions » 2021-12-20 19:34:02

Hi Evan,

thanks for the reply and nice to hear (hope it'll happen in the forseeable future :)).

As to your questions:

Do you use the "app-to-app MIDI" variant or the "direct" variant of the plugins?

Preferably the "direct" variant as the "app-to-app MIDI" variant is an itermediate layer which, generally speaking, takes longer to set up and has no obvious benefit imo.
Though as I'm also a bit involved in plugin development I know about the issue of VST3 plugins and MIDI output which is sad imo, but that's the way it is. For CC output they've introduced LegacyMIDICCOutEvent but I think MIDI notes output is still not possible, is it?
So taking this into account (and Steinberg trying hard to kill VST2) I'd say whatever works is good and may that be "app-to-app MIDI" variant.

In what DAWs?

REAPER is my main DAW.

How you set them up and run them?

Setting up an audio-to-MIDI plugin is very straight forward there.
Just drop in on a track, enable audio input and it spits out MIDI which could be sent to another track and recorded there if desired.

Do you use automation for the plugins' settings?

I do use automation for plugins a lot in general, but for imitone specifically I wouldn't see an immediate use case (maybe for changing imitone's key/scale via automation if key of a project/backing-track changes mid-song.)

Hope this helps. :)

#2 Feedback and Suggestions » 'Equalize' standalone and VST(3) versions » 2021-12-19 20:03:59

nofish
Replies: 3

The VST(3) versions in current package (0.11.0a) still seem to be from 2018 and not updated to the same code the standalone version contains (minus the GUI), is that correct?
If so, could the standalone and VST(3) versions be 'equalized' with releases, containing the same core code please?
(as I'm more interested testing/using the VST versions than standalone).

edit:
Btw. when is a GUI for the VST(3) versions planned?

#3 Fine-Tuning » 0.9.2.g - VST2 install location » 2018-04-26 06:26:57

nofish
Replies: 2

Hi,

first, happy to finally see the VST2 version coming around, yay. Thanks.

About installation of the VST2 plugin:
It seems the installer automatically installs to C:\Program Files\Steinberg\VstPlugins.

I know some other installers do that too but imo better way would be to let the user choose the install location, because as opposed to VST3 where the install location is fixed (C:\Program Files\Common Files\VST3 for 64 bit VST3, C:\Program Files (x86)\Common Files\VST3 for 32 bit VST3) for VST2 plugins install location is not fixed afaik.

For example I don't use the Program Files\Steinberg\VstPlugins path at all for VST2 plugins, all my VST2 plugins go to D:\VST plugins  which means I'll have to move the imitone VST2 to the correct place afterwards.

(Rather a nitpick I wanted to mention though, didn't get around to actually test the VST2 plugin but looking forward to and will post feedback.)

#4 Re: Feedback and Suggestions » "Breath controller" mode (Volume to CC only) » 2017-08-23 12:11:47

Hi Evan,

you're right, there are already VSTs that do that e.g.
http://www.thepiz.org/plugins/?p=AudioToCC

so it's nothing super-important but I thought as imitone kinda almost seems to be there already (with power control expression) so why not ask to add it. :)
I see the point with keeping the interface simple though.

I'll try the transpose value hack, thanks.

Btw., if you ever plan to implement this, attack and release settings (like in the linked VST) would also come in handy.

#5 Feedback and Suggestions » "Breath controller" mode (Volume to CC only) » 2017-08-20 15:44:53

nofish
Replies: 7

I'd like to use imitone as kind of a "poor man's breath controller".

If unfamiliar with breath controllers, you have a mouth piece you blow into which gets converted to CC's (often CC11, expression) which can be used to modulate sample libraries.

e.g.
https://youtu.be/QUJBW9w_MQo?t=107

I'd like to use  the same technique humming or singing in a mic instead and the intensity (volume) getting converted to CC via imitone.
It basically works already currently with "power control expression" enabled, but you have to filter out / delete the notes generated by imitone afterwards (because they are not needed in this case).

So essentially "Power control expression" mode (generating CC's only) without pitch tracking and generating notes.

Thanks for considering.

#6 Re: Bug Reports » 0.9.2 Not starting / Crash on open (solved in 0.9.2a) » 2017-08-03 06:48:37

Can confirm 0.9.2a 64-bit is starting up ok (with JACK disabled).
And 0.9.2a 32-bit version seems to work fine with JackRouter.

Thanks.

CWVx2Kr.jpg

#8 Re: Bug Reports » 0.9.2 Not starting / Crash on open (solved in 0.9.2a) » 2017-07-24 13:48:34

Thanks for having an immediate look Evan.

I wouldn't want to uninstall JACK for Windows because I use it for other things, but I intended to see what's happening if I take out ASIO support.

But there are not yet alternative builds (with viewer audio modes) of the portaudio_x64.dll available or ?
I looked here:
http://imitone.com/munity/viewtopic.php?pid=753#p753

I'm not in a rush though (tbh I'm much more excited about your plugin announcement that came with the 0.9.2 mail) so I'm also fine waiting for the next patch.

edit:
Regarding JACK, I'd guess it's a 32/64 bit issue.

Currently Jack for Windows only supports 32-bit applications

http://www.jackaudio.org/faq/jack_on_windows.html

So imitone 64 bit should probably just ignore it when it 'sees' it I guess.


edit2:
Hm...maybe that info above is outdated.
My DAW is Reaper and I'm usually using the 32 bit version, but I just tried and the 64 bit version is running fine with JackRouter (after registering the 64 bit JackRouter.dll manually).

#9 Bug Reports » 0.9.2 Not starting / Crash on open (solved in 0.9.2a) » 2017-07-23 12:33:38

nofish
Replies: 8

At first when when installing 0.9.2 I got this:

VF2Jss6.jpg

MeqojTs.jpg

Then did a reinstall , now I get a
"App quit unexpectedly (Status: Running)" message when trying to launch.

Specs:
Win 8.1 SP1, NVidia G210

Logs:
https://www.dropbox.com/s/ujwwdox520a4e … s.zip?dl=1

edit:
Also just sent with the in-app error reporter, with a link to this thread.

#10 Re: Bug Reports » 0.5.1c Windows 7 x64 : imitone sending modwheel data w/ vibrato off » 2014-06-18 13:40:38

Fair point with the stuck value when switching a feature off.

But wouldn't it suffice sending a zero state only once immediately in the moment a feature is turned on / off ?
Or maybe a button on the GUI called "reset CC's" ?

Imo sending repeated states (when a feature is turned off) is not so practical, as it can interfere with patches as the OP said or manually recorded controllers.

(I didn't bother to reply twice, but same would go for the other thread, as it's the same topic basically)
http://imitone.com/munity/viewtopic.php?id=54

#12 Feedback and Suggestions » (0.5.1c) Expression vs Volume - small "bug" in the Readme.txt ? » 2014-06-18 09:35:18

nofish
Replies: 1

Quote from the Readme:

The expression switch (peach) enables continuous loudness control when open.  [CC 7]

From testing, it seems imitone is sending CC 11 (expression) rather than CC 7 (volume) when this switch is engaged, no ?
(which I'd consider logical btw., given the name "expression switch" :))

Also I've noticed, when this switched is turned off, imitone still seems to send some fixed CC 11 (value 126) from time to time.

VfUDgrT.jpg

I'd think maybe this shouldn't be (expression switch off = no CC 11 sent at all ?)


And an unrelated thing:

A "always in front" pin / option would probably be nice for the standalone version, because currently it always hides under the DAW when maximised.

Thank you.

#13 Re: Bug Reports » (fixed in 0.5.1c) 0.5.1b - still hanging on the "Loading...." screen » 2014-06-04 17:10:47

Ah, nice bug hunting. Thanks Evan, finally we know the cause. :)
That explains perfectly why it's running fine when I remove aa in the ini.

btw, that blue-screen was a one-timer so far, I've run imitone a few times now and didn't happen again, so not too worrying I think

will report back if it happens again

#14 Bug Reports » (fixed in 0.5.1c) 0.5.1b - still hanging on the "Loading...." screen » 2014-05-30 09:27:51

nofish
Replies: 2

edit:

Starting up fine now in 0.5.1c. Thanks Evan.


--- original post:

Still hanging on the "Loading..." screen here as the previous versions.

Specs:

CPU: Intel Core 2 Quad Q9550
Mainboard: Intel DP43BF
GPU: NVidia GForce G210 512MB

Win 8.1 update1 64bit

custom Windows theme (UXpatcher installed)

error

error.txt

log

log.txt

Evan, we communicated about this before via email, check my email adress I used for registering here, it's the same.

--- edit:

I set up this system just some month ago so the graphics driver is pretty recent, but as I noticed there was a newer one available I just updated today to the latest version to see if this makes any change - unfortunately it didn't.

logs again after updating:


error.txt

log.txt


OpenGL viewer XML

glview-GeForce_210_PCIe_SSE2-6.txt

(rename to .xml, couldn't upload otherwise)


---edit2:

It's starting up ok when I delete "aa on" in the pg.ini

Sorry, just saw this suggested now in the other post.

Now I can finally check it out. :)


---edit3:

Got a BSOD/PC restart

This was with either "exclusive mode" or "kernel mode" as audio input (can't remember exactly)

dump: (rename to *.dmp)

060314-53484-01.txt

Board footer

Powered by FluxBB