imitone community

Building a universal, human-friendly music interface. ...But first we have to fix the bugs!

You are not logged in.

Announcement

Having trouble with imitone? Hit send on any Error Reports it creates, or use the in-app "send feedback" button.

#1 2014-11-03 18:15:03

Evan
creator of imitone
From: Ames, IA
Registered: 2014-05-23
Website

Graphics Troubleshooting

NOTE:  As of version 0.6.1a the below steps are automated in all copies of imitone.  The following guide should now be unnecessary.


Uh-oh!  Start-up error?  Black window?  For some reason imitone won't show up when it's opened!

Graphics Troubleshooting Guide

Background:  imitone was built using videogame technology, and utilizes hardware-accelerated graphics.  This permits quick, responsive action from the interface, but unfortunately can create various compatibility problems depending on the graphics card in the computer being used.  These have been troublesome throughout imitone's development and I'm working to isolate and fix them, one by one.

This guide assumes you have one of the following problems:

  • Startup Error -- imitone does not start up properly, and shows an error pop-up or screen.

  • Render Error -- imitone opens but the window is black or garbled.

  • No Acceleration -- imitone opens but the edges are jagged on the graphics and the program runs very slowly.

These problems can often be worked around -- but it's helpful to report them first, and to report whether the steps below helped to fix them.  That information will help me to make imitone work out-of-the-box, so these problems don't happen in the first place.


Method 1:  Edit your pg.ini file to use more basic settings.

  • Use notepad or TextEdit to open the file.

    • On Windows, this is located at C:\Program Files (x86)\interactopia\imitone Beta 0.6.1\pg.ini or similar.

    • On Mac, option-click the imitone app and choose "show package contents", then go to Contents -> Resources.

  • Find and delete this line: #set graphics.debug 1

  • Replace it with: #set graphics.screen_multisample 0


Method 2:  Update your computer's graphics drivers.

(This work-around mainly applies to Windows computers.  If you use a Mac, the best approach is to apply automatic updates or upgrade to a newer version of OS X.)

It's difficult to give specific instructions here, as the proper drivers depend on your graphics card.  Most cards are ATI, nVidia or Intel -- determine your card's manufacturer and go to their website for further instructions.  Adobe has written guides for Windows Vista, 7 and 8, Windows XP and

Offline

#2 2014-11-03 19:15:05

musica
Member
Registered: 2014-11-03

Re: Graphics Troubleshooting

For some reason,I get an 'access denied' message when I try to save pg.ini after the edit.
My system says my graphics driver is up-to-date. Sorry,I don't know and can't find a model# for the Intel graphics card.
It's the standard graphics card for a Dell Inspiron laptop with Windows 7.

Offline

#3 2014-11-03 20:05:19

musica
Member
Registered: 2014-11-03

Re: Graphics Troubleshooting

I find that the interactopia folder was installed as read-only.

Offline

#4 2014-11-03 20:51:06

Evan
creator of imitone
From: Ames, IA
Registered: 2014-05-23
Website

Re: Graphics Troubleshooting

You should be able to right-click in the folder (or on the pg.ini file) and remove the read-only property.  It might require you to type your password.

Offline

#5 2014-11-03 21:42:30

musica
Member
Registered: 2014-11-03

Re: Graphics Troubleshooting

System won't let me unset the read-only attribute even though I'm logged on as admin.
I get the message - you will need to provide administrator permission to change these attributes.


Finally,I got my user account/security problem resolved.

I made the edit to pg.ini and there is start up. Yay!

Last edited by musica (2014-11-04 07:02:18)

Offline

Board footer

Powered by FluxBB