imitone community

Building a universal, human-friendly music interface. ...But first we have to fix the bugs!

You are not logged in.

Announcement

Having trouble with imitone? Hit send on any Error Reports it creates, or use the in-app "send feedback" button.

#1 2015-02-06 18:00:26

metamorphosis
Member
Registered: 2014-08-07

Pitch bend clipping notes

Briefly, with pitch glide and bend turned on, imitone does a nice approximation of continuous sliding notes, but also has a tendency to clip them off into new notes after a while, even when the audio level from the mic stays constant (using headphones and imitone for feedback). Would be better if there were better handling of continous notes.

Offline

#2 2015-02-07 11:28:59

Yragael
Power Tester
From: Belgium
Registered: 2014-05-30
Website

Re: Pitch bend clipping notes

the answer could be there: http://imitone.com/munity/viewtopic.php?id=117

in short, what you are struggling with is pitchbend range amount.

By default imitone is set to 2 semitones up and down for pitchbending [like usual vsti on the market]
Now you can edit the xml file to fit it to your needs.

I edited it to work with +12 -12 pitchbending, I then had to set pitchbend accordingly for the synths.
Result long glide with no stopping.

Evan wrote:

An explanation of the problem:  The pitch bend controller adjusts a MIDI instrument's pitch within an undefined and typically small semitone range.  It's most often two semitones, but can be one, and occasionally instruments use a one-octave range.  There is a feature to control an instrument's pitch bend range, but unfortunately many patches don't respond to that control -- so I use the safest value -- 2 -- by default.
It's possible to change the default range by editing the configuration.  (I may make it an option in the program later.)
1:  Open imitone.
2:  Turn on pitch-bend.
3:  Click in the imitone interface for focus, and press control-R to pop up its settings folder.
4:  Close imitone (do this NOW or the change won't take!)
5:  Open config.xml in notepad.
6:  Look for the line with the <Pitch ... > tag, EG. <Pitch mode="0" range="2" tolerance="0.25" transpose="-12"/>
7:  Edit the number after range= to be "12".
8:  Save the file.
9:  Open imitone again.

best regards

Offline

#3 2015-02-07 14:58:30

Evan
developer
From: Seattle, WA
Registered: 2014-05-23
Website

Re: Pitch bend clipping notes

I actually made this a bit easier in 0.7.0.  Hold CONTROL (or COMMAND) when you click the pitch-bend button to turn it on.  This will set a bend-range of 36 semitones rather than the usual two.  However, with the current abundance of off-notes produced by the algorithm the effect can at times be a little disconcerting...

Offline

#4 2015-02-07 15:26:29

metamorphosis
Member
Registered: 2014-08-07

Re: Pitch bend clipping notes

Will give it a go-

Offline

#5 2015-02-27 20:07:23

metamorphosis
Member
Registered: 2014-08-07

Re: Pitch bend clipping notes

CTRL does nothing to fix the note-clipping behaviour - still aliasing down to notes all over the show, regardless of the consistency of signal.

The XML editing instructions also had no effect.

Also have noticed that merely having imitone open while reaper 4.77 is running, seems to bring up the synth vsti on the track that imitone input is enabled on.
I don't know what causes this, but it's constantly refreshing to the forefront of all windows, blocking out imitone.

Last edited by metamorphosis (2015-02-27 20:13:23)

Offline

#6 2015-03-23 14:38:19

Evan
developer
From: Seattle, WA
Registered: 2014-05-23
Website

Re: Pitch bend clipping notes

Hey, meta --

Yeah, those brief "ghost notes" are one of 0.7.0's big problems.  Working on that.

No idea what the reaper problem is; it must be reacting to some message imitone is sending.  (Legato pedal, maybe?)  To confirm this, try hitting the "power" button on the imitone interface.  Also try switching some of the different modes on / off.  It could be because imitone is being treated as a "control surface", whose messages can control the DAW -- that's generally a script you can shut off in the MIDI settings.

Offline

#7 2015-04-05 23:48:28

metamorphosis
Member
Registered: 2014-08-07

Re: Pitch bend clipping notes

Found the problem with Reaper, the midi device was set up by default as 'input + control' - once 'control' was turned off it was all good.

Ghost notes are still the most problematic part of usage, I can't even do pizzicata strings because it just creates dozens of hits at a time, rather than averaging the one hit.

Offline

Board footer

Powered by FluxBB